Website under development
Resolved
Website up and running
Posted Sep 22, 2021 - 17:10 UTC
Monitoring
Domain name has been verified and we have moved to the development process
Posted Jul 26, 2021 - 07:36 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 20, 2021 - 09:53 UTC
This incident affected: Website and Emails server.